Brother Scanner not Found on Linux Mint 18.1 and Ubuntu 16.04 – Fixed!

I’ve previously posted about my Brother MFC-7840N printing slowly, but since then Brother updated their driver package for Linux and everything was going quite smoothly. Unfortunately, after I upgraded from Linux Mint 17.3 to Linux Mint 18.1 today, the Brother Linux drivers failed to activate the scanner. When I started XSane it said there was no scanner found.

After a lot of re-installing of drivers and scanner configurations I found the problem was simply some missing files. It seems sane must be looking for information in the standard directories and not where the 64-bit libraries are.

Anyway, here are the commands to run to make your Brother scanner work with Linux Mint and Ubuntu.

sudo mkdir /usr/lib/sane
sudo ln -s /usr/lib64/sane/libsane-brother3.so /usr/lib/sane/libsane-brother3.so
sudo ln -s /usr/lib64/sane/libsane-brother3.so.1 /usr/lib/sane/libsane-brother3.so.1
sudo ln -s /usr/lib64/sane/libsane-brother3.so.1.0.7 /usr/lib/sane/libsane-brother3.so.1.0.7
sudo ln -s /usr/lib64/libbrscandec3.so /usr/lib/libbrscandec3.so
sudo ln -s /usr/lib64/libbrscandec3.so.1 /usr/lib/libbrscandec3.so.1
sudo ln -s /usr/lib64/libbrscandec3.so.1.0.0 /usr/lib/libbrscandec3.so.1.0.0

If you are already logged in as root (naughty you!) then just use the same commands without sudo.

mkdir /usr/lib/sane
ln -s /usr/lib64/sane/libsane-brother3.so /usr/lib/sane/libsane-brother3.so
ln -s /usr/lib64/sane/libsane-brother3.so.1 /usr/lib/sane/libsane-brother3.so.1
ln -s /usr/lib64/sane/libsane-brother3.so.1.0.7 /usr/lib/sane/libsane-brother3.so.1.0.7
ln -s /usr/lib64/libbrscandec3.so /usr/lib/libbrscandec3.so
ln -s /usr/lib64/libbrscandec3.so.1 /usr/lib/libbrscandec3.so.1
ln -s /usr/lib64/libbrscandec3.so.1.0.0 /usr/lib/libbrscandec3.so.1.0.0

Hopefully this post saves some time for a few people and will remind me what to do when I hit the same problem with my Brother MFC-7840N scanner not being found!



Leave a Reply

Your email address will not be published. Required fields are marked *

Anti-Spam Test :) * Time limit is exhausted. Please reload the CAPTCHA.